#451 [↑][↓]  21-09-2017 15:54:31

Tomy
Copilote
Lieu: Sucy-en-Brie - LFPO
Date d'inscription: 03-04-2011
Renommée :   

Re: [FS9][FSX][P3D] Tuto SPAD l'ami des panels Saitek... Enfin dispo P3Dv4

Salut les Amis,
Dans mon dernier post, je parlais de réinstaller windows vu mon problème avec le Multipanel. Je n'ai pas eu à le faire parce que depuis tout fonctionne normalement....  et je n'ai pas la moindre idée sur la correction du problème. Et lorsque que cela arrive encore (très rare), je ferme Spad, je le relance et c'est OK. Les causes peuvent venir de Windows 10, de P3Dv4 (peut-être) de SPAD, sans exclure les modules eux même. wacko

De plus j'ai une panne mécanique avec mon Switch panel, les boutons du bas (section Light), à part le Panel Light, tous sont  hors service e_colere. Donc je me retrouve avec un Switch qui fonctionne à moitié... je l'ai retiré de mon installation.
Il ne me reste plus que le MultiPanel et le RadioPanel. Au fur et à mesure de leur départ à la retraite les Saitek ne seront pas remplacés....
Si un jour Logitech retrousse ses manches pour nous offrir un truc vraiment Plug and Play je verrai.
Merci Bô pour ton aide encore avec ton dernier tuto... Un conseil Bô, reste sur Win 7 autant que tu le pourras....
A +
Bons vols


Alain
i7 2600 K - EVGA GTX 1070  -  SSD 120  win 10 - SSD 240  P3D v4.3 -
HDD WD CB 1 TO - RAM 16 GO - 3 écrans LG 24 pouces -ThrustMaster - Saitek - GoFlight- Precision Flight controls

Hors ligne

 

#452 [↑][↓]  21-09-2017 18:06:38

Usul
Copilote
Membre donateur
Lieu: LFBH
Date d'inscription: 18-11-2008
Renommée :   
Site web

Re: [FS9][FSX][P3D] Tuto SPAD l'ami des panels Saitek... Enfin dispo P3Dv4

Bobonhom a écrit:

Que veux tu dire par avoir les gauches, puisque je les ai???

Les afficher sur les FIP???

Pour avoir les gauges sur les FIP.


P3D - DCS World - Xplane 11 - i7 7700K@4.2/4.5Ghz - MSI Z270 SLI PLUS - RTX 2070 - 32Go DDR4 - SSD 512 Go EVO 850 pro - SSD 1To EVO 850 - SSD 500Go EVO 960 M.2 - W10 64bits - Warthog - Pro Flight Radio - Pro Flight Switch Panel -  Pro Flight Multi Panel - Throttle Quadrant CHproduct- 2x FIP - Pro Pedals - TrackIR 5 - 2x MFD - écran Samsung 34" curved

Hors ligne

 

#453 [↑][↓]  21-09-2017 18:32:58

Bobonhom
Pilote Virtuel
Membre donateur
Lieu: Les Laurentides Québecoise
Date d'inscription: 24-04-2012
Renommée :   119 
Site web

Re: [FS9][FSX][P3D] Tuto SPAD l'ami des panels Saitek... Enfin dispo P3Dv4

Ah OK, ça c'est pas pareil... Je vais trouver wink


https://i.goopics.net/oYwXe.jpghttps://i.goopics.net/4Wd7b.jpghttps://i.goopics.net/20XRJ.jpg

Hors ligne

 

#454 [↑][↓]  22-09-2017 00:26:11

androl2015
Pilote Virtuel
Lieu: LFML 61 ans
Date d'inscription: 12-09-2015

Re: [FS9][FSX][P3D] Tuto SPAD l'ami des panels Saitek... Enfin dispo P3Dv4

Usul a écrit:

@ Androl, peux tu vérifier dans ton répertoire Programmes (et non program files (x86)) la présence d'un répertoire Saitek et son contenu?
Merci!

oups  je t'avais oublié

sorry

http://www.easy-upload.net/fichiers/usul.20179220274.jpg

http://www.easy-upload.net/fichiers/usul_1.201792202541.jpg


http://www.easy-upload.net/fichiers/usul2.20179220267.jpg

Dernière modification par androl2015 (22-09-2017 00:27:07)


Avatar : Jean-Baptiste Monge / w10 / i7 8700K / 3.6 GHz / RAM 32 Go / SSD 1T / HD 1T externe / GTX 1080ti / 2 écrans 10" / 1-24 "et 1-34 " en 21/9 / 1 Ipad /joystick X 52 -Switch Panel- Multi Panel - Radio Panel -BIP- et FIP Saitek /EFIS et MCP Goflight /FCU Skalarki,  soft  en bêta test / X-Plane 11.31 

Hors ligne

 

#455 [↑][↓]  22-09-2017 01:43:18

Bobonhom
Pilote Virtuel
Membre donateur
Lieu: Les Laurentides Québecoise
Date d'inscription: 24-04-2012
Renommée :   119 
Site web

Re: [FS9][FSX][P3D] Tuto SPAD l'ami des panels Saitek... Enfin dispo P3Dv4

Je viens d'avoir une idée wink

Si on met juste le dossier DirectOuput avec ce qui a dedans, mais sans installer le plugin FSX_Plugin_x64_Software... Probablement que les drivers des autre pro panel ne serait donc pas installer, mais peut être que les fip marcherait, car je crois pas qu'ils ont besoin de d'autre chose ailleurs... ???

Il faut donc qu'une copie de ce dossier pour tester cette piste wink

Dernière modification par Bobonhom (22-09-2017 01:47:33)


https://i.goopics.net/oYwXe.jpghttps://i.goopics.net/4Wd7b.jpghttps://i.goopics.net/20XRJ.jpg

Hors ligne

 

#456 [↑][↓]  22-09-2017 08:48:27

Usul
Copilote
Membre donateur
Lieu: LFBH
Date d'inscription: 18-11-2008
Renommée :   
Site web

Re: [FS9][FSX][P3D] Tuto SPAD l'ami des panels Saitek... Enfin dispo P3Dv4

Merci Androl! Ça confirme ce que je craignais, à savoir la même structure que les fichiers logitech.

@Tomy, je ne crois pas que cela soit un problème de W10. C’est surtout une adaptation difficile de la version 64bits de P3D. Donc avec un W7, ça sera pareil.

@Bo, j’ai fait des essais avec juste soit le driver seul, soit le plugin seul. Ça ne donne rien.


P3D - DCS World - Xplane 11 - i7 7700K@4.2/4.5Ghz - MSI Z270 SLI PLUS - RTX 2070 - 32Go DDR4 - SSD 512 Go EVO 850 pro - SSD 1To EVO 850 - SSD 500Go EVO 960 M.2 - W10 64bits - Warthog - Pro Flight Radio - Pro Flight Switch Panel -  Pro Flight Multi Panel - Throttle Quadrant CHproduct- 2x FIP - Pro Pedals - TrackIR 5 - 2x MFD - écran Samsung 34" curved

Hors ligne

 

#457 [↑][↓]  22-09-2017 20:03:08

Bobonhom
Pilote Virtuel
Membre donateur
Lieu: Les Laurentides Québecoise
Date d'inscription: 24-04-2012
Renommée :   119 
Site web

Re: [FS9][FSX][P3D] Tuto SPAD l'ami des panels Saitek... Enfin dispo P3Dv4

Je crois que tu n'a pas bien compris e que je voulais faire...

1- Installer Flight_Instrument_Panel_x64_Drivers pour avoir les gauge et drivers FIP

2- Copier que le dossier DirectOuput dans le bon répertoire, mais sans installer FSX_Plugin_x64_Software, pour que le logiciel des FIP y retrouve ce qu'il a de besoin... Mais sans avoir les drivers des autre Pro panel qui cause problème à SPAD

Pour ce faire... Je vais installer FSX_Plugin_x64_Software sur un autre ordi, et récupéré que le fichier DirectOuput

Et si ça marche pas, je vais trouver ce que les FIP on besoin dans ce foutu fichier...

Dernière modification par Bobonhom (22-09-2017 20:05:00)


https://i.goopics.net/oYwXe.jpghttps://i.goopics.net/4Wd7b.jpghttps://i.goopics.net/20XRJ.jpg

Hors ligne

 

#458 [↑][↓]  29-09-2017 12:43:58

Usul
Copilote
Membre donateur
Lieu: LFBH
Date d'inscription: 18-11-2008
Renommée :   
Site web

Re: [FS9][FSX][P3D] Tuto SPAD l'ami des panels Saitek... Enfin dispo P3Dv4

Bonjour. Toujours à la recherche d'une solution pour faire cohabiter FIP et spad0.7.
Je cherche donc un driver saitek pour FIP  qui installe un exécutable saiPanels.exe dans le répertoire suivant : C:\Program Files (x86)\Saitek\Pro Flight Panels\SaiPanels.exe.

Je l'ai eu à une époque mais perdu depuis. C'est l'éxécutable dont on a besoin pour faire fonctionner seul les FIP sans les autres équipements saitek.


P3D - DCS World - Xplane 11 - i7 7700K@4.2/4.5Ghz - MSI Z270 SLI PLUS - RTX 2070 - 32Go DDR4 - SSD 512 Go EVO 850 pro - SSD 1To EVO 850 - SSD 500Go EVO 960 M.2 - W10 64bits - Warthog - Pro Flight Radio - Pro Flight Switch Panel -  Pro Flight Multi Panel - Throttle Quadrant CHproduct- 2x FIP - Pro Pedals - TrackIR 5 - 2x MFD - écran Samsung 34" curved

Hors ligne

 

#459 [↑][↓]  29-09-2017 14:14:49

androl2015
Pilote Virtuel
Lieu: LFML 61 ans
Date d'inscription: 12-09-2015

Re: [FS9][FSX][P3D] Tuto SPAD l'ami des panels Saitek... Enfin dispo P3Dv4

Salut ,
je regarde ce soir en rentrant du boulot ....


Avatar : Jean-Baptiste Monge / w10 / i7 8700K / 3.6 GHz / RAM 32 Go / SSD 1T / HD 1T externe / GTX 1080ti / 2 écrans 10" / 1-24 "et 1-34 " en 21/9 / 1 Ipad /joystick X 52 -Switch Panel- Multi Panel - Radio Panel -BIP- et FIP Saitek /EFIS et MCP Goflight /FCU Skalarki,  soft  en bêta test / X-Plane 11.31 

Hors ligne

 

#460 [↑][↓]  29-09-2017 20:04:08

androl2015
Pilote Virtuel
Lieu: LFML 61 ans
Date d'inscription: 12-09-2015

Re: [FS9][FSX][P3D] Tuto SPAD l'ami des panels Saitek... Enfin dispo P3Dv4

Usul a écrit:

Bonjour. Toujours à la recherche d'une solution pour faire cohabiter FIP et spad0.7.
Je cherche donc un driver saitek pour FIP  qui installe un exécutable saiPanels.exe dans le répertoire suivant : C:\Program Files (x86)\Saitek\Pro Flight Panels\SaiPanels.exe.

Je l'ai eu à une époque mais perdu depuis. C'est l'éxécutable dont on a besoin pour faire fonctionner seul les FIP sans les autres équipements saitek.

edit ,

mis en MP


Avatar : Jean-Baptiste Monge / w10 / i7 8700K / 3.6 GHz / RAM 32 Go / SSD 1T / HD 1T externe / GTX 1080ti / 2 écrans 10" / 1-24 "et 1-34 " en 21/9 / 1 Ipad /joystick X 52 -Switch Panel- Multi Panel - Radio Panel -BIP- et FIP Saitek /EFIS et MCP Goflight /FCU Skalarki,  soft  en bêta test / X-Plane 11.31 

Hors ligne

 

#461 [↑][↓]  30-09-2017 12:11:04

Usul
Copilote
Membre donateur
Lieu: LFBH
Date d'inscription: 18-11-2008
Renommée :   
Site web

Re: [FS9][FSX][P3D] Tuto SPAD l'ami des panels Saitek... Enfin dispo P3Dv4

Merci Androl, bien reçu. Je continue mes tests mais rien de probant pour l'instant.


P3D - DCS World - Xplane 11 - i7 7700K@4.2/4.5Ghz - MSI Z270 SLI PLUS - RTX 2070 - 32Go DDR4 - SSD 512 Go EVO 850 pro - SSD 1To EVO 850 - SSD 500Go EVO 960 M.2 - W10 64bits - Warthog - Pro Flight Radio - Pro Flight Switch Panel -  Pro Flight Multi Panel - Throttle Quadrant CHproduct- 2x FIP - Pro Pedals - TrackIR 5 - 2x MFD - écran Samsung 34" curved

Hors ligne

 

#462 [↑][↓]  17-10-2017 11:04:47

Yanick a320
Elève Pilote
Date d'inscription: 08-11-2009
Renommée :   

Re: [FS9][FSX][P3D] Tuto SPAD l'ami des panels Saitek... Enfin dispo P3Dv4

Bonjour

j'ai acquis récemment les saitek panel swicht et radio. Je suis avec FS9. J'ai installé SPAD version 05.1. J'utilise la version fsuipc payante.
Je rencontre des difficultés dans le fonctionnement de mes boutons du panel swicht. Je m'explique

si je choisis de programmer mes boutons swicht avec la fonction keyboard emulation, dans fs lorsque j'appuie sur un des boutons programmés dans spad, d'autres boutons s'actionnent. Par exemple j'appuie sur panel pour allumer mon cockpit (assigné à la touche T dans spad), le cockpit s'allume mais également deice (qui lui est assigné à la lettre I dans SPAD). dans FS bien évidemment deice est assigné à la touche I et panel light est assigné à la lettre T.


si je choisis de programmer mes boutons swicht avec la fonction fsuipc virtal button, j'ai le même problème. Dans SPAD j'assigne la touche deice on a 64-0 et la touche deice off a 64-1. Panel lignt assigné dans spad à panel on 64-2 et panel off à 64-3. Dans fsuipc le bouton 64-0 assigné à  la touche T et 64-1 assigné à al touche t également, le bouton 64-2 et 64-3 assigné à I.
quand j'appuie sur panel pour allumer mon cockpit , le cockpit s'allume mais également deice .

si je quitte fs sans quitter SPAD et que je relance fs, alors tout fonctionne correctement. le bouton pane allume uniquement le cockpit et le bouton deice uniquement deice dans fs.

j'ai beau désinstaller spad, supprime rle fichier défaut .ini de spad restant, effacer dans fspuic.ini l'affectation des boutons 64-0 à 64-4, j 'ai toujours le même résultat.

Une aide charitable me sera agréable.

merci à vous

yanick

Hors ligne

 

#463 [↑][↓]  17-10-2017 11:55:38

Yanick a320
Elève Pilote
Date d'inscription: 08-11-2009
Renommée :   

Re: [FS9][FSX][P3D] Tuto SPAD l'ami des panels Saitek... Enfin dispo P3Dv4

Je viens d eme rendre compte d une chose. En fait cela ce passe avec n importe quel bouton programmer dans spad et ce uniquement au premier lancement de fs9. Si je quitte fis et le relance tout fonctionne correctement. Des le premier lancement de fs9 et que spad soit lancé avant ou après fs le premier bouton actionné dans fs9 et qu’il est programmé dans spad soit par keybooard émulation soit par fsuipc virtuel provoque une action sur tous le sujet boutons programmés dans spad avec keyboard émulation ou fsuipc virtuel. J ai installé la version 5,1 et essayé également avec la verse 5.p toujours le même résultat.
Dans le radio panel compte tenu que je n ai rien programmé tout fonctionne correctement pour radio panel

Hors ligne

 

#464 [↑][↓]  17-10-2017 11:57:37

Usul
Copilote
Membre donateur
Lieu: LFBH
Date d'inscription: 18-11-2008
Renommée :   
Site web

Re: [FS9][FSX][P3D] Tuto SPAD l'ami des panels Saitek... Enfin dispo P3Dv4

Bonjour,
Si tu as installé les drivers saitek, il faut impérativement que tu les desinstalles pour pouvoir utiliser SPAD. Ce dernier se substitue aux drivers saitek.
Ensuite, par défaut, pas besoin de programmer les boutons des panels avec FSUIPC sauf si tu veux une action particulière qui n’existe pas par défaut.
Si tu veux quelque chose de particulier : soit tu reprogrammes  le bouton directement avec SPAD, soit effectivement tu le fais avec FSUIPC.
Dans tous les cas, pas de drivers saitek avec spad


P3D - DCS World - Xplane 11 - i7 7700K@4.2/4.5Ghz - MSI Z270 SLI PLUS - RTX 2070 - 32Go DDR4 - SSD 512 Go EVO 850 pro - SSD 1To EVO 850 - SSD 500Go EVO 960 M.2 - W10 64bits - Warthog - Pro Flight Radio - Pro Flight Switch Panel -  Pro Flight Multi Panel - Throttle Quadrant CHproduct- 2x FIP - Pro Pedals - TrackIR 5 - 2x MFD - écran Samsung 34" curved

Hors ligne

 

#465 [↑][↓]  17-10-2017 12:08:51

Yanick a320
Elève Pilote
Date d'inscription: 08-11-2009
Renommée :   

Re: [FS9][FSX][P3D] Tuto SPAD l'ami des panels Saitek... Enfin dispo P3Dv4

Merci pour la réponse
Les drivers de saitek ne sont pas installés. Je ne comprends pas pourquoi cela se passe uniquement au premier lancement de fs9.

Hors ligne

 

#466 [↑][↓]  17-10-2017 13:24:08

Bobonhom
Pilote Virtuel
Membre donateur
Lieu: Les Laurentides Québecoise
Date d'inscription: 24-04-2012
Renommée :   119 
Site web

Re: [FS9][FSX][P3D] Tuto SPAD l'ami des panels Saitek... Enfin dispo P3Dv4

Bonjour Yannick...

De un, merci pour le mot d'encouragement pour mon tuto par MP, très apprécié

Si tu assigne des touches clavier, il faut bien sûr qu'elles ne servent pas à d'autre chose dans la liste d'attribution des commandes de FS9 et qu'elles soit existantes dans cette même liste...



Cette parti, je comprend vraiment pas:

si je choisis de programmer mes boutons swicht avec la fonction fsuipc virtal button, j'ai le même problème. Dans SPAD j'assigne la touche deice on a 64-0 et la touche deice off a 64-1. Panel lignt assigné dans spad à panel on 64-2 et panel off à 64-3. Dans fsuipc le bouton 64-0 assigné à  la touche T et 64-1 assigné à al touche t également, le bouton 64-2 et 64-3 assigné à I.
quand j'appuie sur panel pour allumer mon cockpit , le cockpit s'allume mais également deice

Si tu choisi de programmer par virtuel bouton, il te faut attribuer les commande par FSUIPC:

Tu déroule la fenêtre et tu choisi la fonction qu'il te faut, voir si il y a une fonction ON et Off ou fonction toggle...

Mais en tout les cas assigne pas de touche clavier ici, mais les commande de la liste de FSUIPC...

Comme par exemple BRAKES et YAW DAMPER OFF ici:

http://nsm08.casimages.com/img/2014/05/06//14050602292116200212210763.jpg

Quelques exemples de light dans la liste FSUIPC:

LANDING LIGHT DOWN 65863
LANDING LIGHT HOME 65866
LANDING LIGHT LEFT 65864
LANDING LIGHT RIGHT 65865
LANDING LIGHT UP 65862
LANDING LIGHTS OFF 66060
LANDING LIGHTS ON 66059
LANDING LIGHTS SET 66061
LANDING LIGHTS TOGGLE 65751
PANEL LIGHTS OFF 66057
PANEL LIGHTS ON 66056
PANEL LIGHTS SET 66058
PANEL LIGHTS TOGGLE 65750
TOGGLE BEACON LIGHTS 66239
TOGGLE CABIN LIGHTS 66579
TOGGLE LOGO LIGHTS 66376
TOGGLE NAV LIGHTS 66379
TOGGLE RECOGNITION LIGHTS
TOGGLE STRUCTURAL DEICE 66337
TOGGLE TAXI LIGHTS 66240
TOGGLE WING LIGHTS 66378

Maintenant concernant ceci:

Je viens d eme rendre compte d une chose. En fait cela ce passe avec n importe quel bouton programmer dans spad et ce uniquement au premier lancement de fs9. Si je quitte fis et le relance tout fonctionne correctement. Des le premier lancement de fs9 et que spad soit lancé avant ou après fs le premier bouton actionné dans fs9 et qu’il est programmé dans spad soit par keybooard émulation soit par fsuipc virtuel provoque une action sur tous le sujet boutons programmés dans spad avec keyboard émulation ou fsuipc virtuel. J ai installé la version 5,1 et essayé également avec la verse 5.p toujours le même résultat.

Ça j'en ai parlé dans mon tuto

Il faut premièrement que les boutons soit tous bien placer physiquement avec ta situation cold and dark... Car la position des interrupteurs n'est pas lu...

Deuxièmement, il faut réveillé le module Saitek avant de lancer l'avion... Moi je le fais par un aller retour du train, du rotateur d'ignition et par un aller retour sur au moins un swicht après ouverture FS... Puis après seulement je pénètre au cockpit...

Voici comment je l'avais annoncé dans mon tuto:

RECONNAISSANCE DES MODULES SAITEK

A chaque fois que vous allez démarrer SPAD, celui-ci fera une reconnaissance de vos modules Saitek branchés (on le voit visuellement car il allume les LEDs des modules à tour de rôle), mais FSX, P3D ou FSUIPC n'auront pas nécessairement détecté les modules Saitek correctement au travers de SPAD...

La reconnaissance des modules Saitek sous FSX/P3D est parfois capricieuse et peut poser problèmes en vol... Les quatre modules concernés par SPAD pour ce qui est du positionnement des boutons au travers de FSUIPC, mais aussi du Trim wheel qui demande à être réveillé pour être lu par FSX/P3D, voici comment je m'en tire bien:


TRUC ET ASTUCES La reconnaissance des modules Saitek par FSX/P3D doit ce faire avant pénétration dans le cockpit pour ne pas avoir de problème au décollage... Par exemple, chez moi, tout peut ce mettre à OFF lorsque je rentre le train au décollage sans reconnaissance du positionnement des interrupteurs avant (voir mes chroniques d'un CATALINA et mes déboires en décollage sur IVAO ici) wink

On le voit facilement lorsqu'on actionne le trim wheel Saitek la première fois en vol, il y a un temps de réponse car il n'avait pas été reconnu ou réveillé avant (on entend les petites cloches Windows de reconnaissance USB)...

Dans le menu FSX/P3D, donc avant pénétration dans mon cockpit, j'actionne quelques swicht de tout mes modules capricieux (Wheel trim, le Multi panel et les Swicht pannel sont assez capricieux en reconnaissance) pour être sûr du bon fonctionnement, une routine à ajouter au Check-list pré embarquement en même tant qu'on s'assure que tout les interrupteurs sont en bonne position avant de pénétrer dans son cockpit en cold and dark...

Pour le Multi panel, c'est l'auto-arm qui est sensible, donc un petit aller retour sur ce swicht...

Pour le Swicht panel, c'est sur le levier du train, le sélecteur magnéto et au moins un swicht que je fais un aller/retour...

Pour le Wheel Trim, juste le bouger un peu, il sera réveillé de suite...

Et voilà, une petite routine simple de quelque secondes qui peut régler certains problèmes et désagréments en vol, de par mon expérience...

J'espère avoir bien cerné ton problème, n'hésite pas a revenir nous indiqué si c'est résolu ou non...

Bonne chance!

Dernière modification par Bobonhom (17-10-2017 13:45:40)


https://i.goopics.net/oYwXe.jpghttps://i.goopics.net/4Wd7b.jpghttps://i.goopics.net/20XRJ.jpg

Hors ligne

 

#467 [↑][↓]  17-10-2017 13:29:57

Yanick a320
Elève Pilote
Date d'inscription: 08-11-2009
Renommée :   

Re: [FS9][FSX][P3D] Tuto SPAD l'ami des panels Saitek... Enfin dispo P3Dv4

Bonjour Bobonhom

Merci pour ta réponse. Effectivement si j actionne un bouton du panel swicht au niveau de le cran de fs9 avant de lancer mon vol, je me suis rendu compte que mon problème disparaissait et que tôt fonctionnait normalement. J alllais lu dans ton Tuto le petit mot sur le réveil du saitek mais n avait pas fait le lien avec mon problème. Quoi qu il en soit, encore bravo pour ton Tuto et la idée que tu m’as apporté.
Bien amicalement
Yanick

Hors ligne

 

#468 [↑][↓]  17-10-2017 13:47:53

Bobonhom
Pilote Virtuel
Membre donateur
Lieu: Les Laurentides Québecoise
Date d'inscription: 24-04-2012
Renommée :   119 
Site web

Re: [FS9][FSX][P3D] Tuto SPAD l'ami des panels Saitek... Enfin dispo P3Dv4

Ah OK, c'est bien ça alors.... wink

Si tu savais les problèmes que j'ai eu avec ça, quand tu rentre le train et que tous ce met OFF dans le cockpit au départ d'un vol en groupe sous IVAO, ça va pas bien big_smile big_smile Et tu passe pour un pas bon quand ton avion se pose sur le ventre en bout de piste en partant wink

Avec ma petit routine, le problème n'est pu jamais revenu...

Et bien tant mieux que tout soit bien résolu...

N'hésite pas si tu as d'autres questions, je charge pas cher wink


Bon vol!



EDIT:

Illustration du déboire en question wink  Faut comprendre qu'à ce moment là, je ne savait pas d'où venait le problème encore wink

http://img11.hostingpics.net/pics/381216ChroniqueB00041.jpg

Dernière modification par Bobonhom (17-10-2017 13:57:31)


https://i.goopics.net/oYwXe.jpghttps://i.goopics.net/4Wd7b.jpghttps://i.goopics.net/20XRJ.jpg

Hors ligne

 

#469 [↑][↓]  28-10-2017 18:42:00

Bobonhom
Pilote Virtuel
Membre donateur
Lieu: Les Laurentides Québecoise
Date d'inscription: 24-04-2012
Renommée :   119 
Site web

Re: [FS9][FSX][P3D] Tuto SPAD l'ami des panels Saitek... Enfin dispo P3Dv4

Je remonte mon topic pour signaler que le problème d'USUL est réglé

Il existe bien un driver pour les FIP (Flight Instrument Panel) seulement et en 64 bits

Donc, oui, il est encore possible d'avoir SPAD pour P3D v4 en même temps que les FIP... Et sans installer le plugin général de Saitek qui déposera les drivers de tout vos panel sur votre ordi et bousillera le fonctionnement de SPAD

Voici le lien vers le drivers FIP Saitek 64 bit: https://mega.nz/#!pJVSGSZC!4F2MRIkViz_7 … YueY_gu-UQ
Si dans l'avenir, ce lien ne marche pu, avertissez moi wink

Et voilà, ce "driver" ne vise que les FIP, donc pas de souci à utiliser avec SPAD, on installe puis on modifie le exe.xml Selon la procédure ci-joint, et BINGO

Pour SPAD P3Dv4, et bien, comme déjà démontré, on installe le SPAD original v,0.5.1, puis on change le "laucher" pour le 0.7.0, voir tuto en page 1...

Bonne journée!

Comment modifier le fichier exe.xml pour que vos FIP soit fonctionnel avec votre simu

Premièrement le chemin normal pour le fichier exe.xml

C:\Users\"ton nom"\AppData\Roaming\Lockheed Martin\Prepar3D

1- Faire une copie de sauvegarde de exe.xml où vous voulez par sécurité...
2- Ouvrir exe.xml avec le "bloc notes" et voir si les lignes de code pour les FIP sont en place? Normalement non...

Si oui, vérifiez que le chemin <Path>C:\Program Files (x86)\Saitek\DirectOutput\SaiFlightSimX.exe</Path> est le bon pour mener à l'exécutif SaiFlightSimX.exe sur ton ordi...

Si non, rajoutez manuellement ces lignes juste avant la dernière ligne </SimBase.Document>

<Launch.Addon>
        <Name>Saitek DirectOutput RadioStack</Name>
        <Disabled>False</Disabled>
        <Path>C:\Program Files (x86)\Saitek\DirectOutput\SaiFlightSimX.exe</Path>
        <CommandLine>-run</CommandLine>
</Launch.Addon>

*Le nom placé en lignes <Name>.....</Name> N'a pas vraiment d'importance, moi j'ai Saitek DirectOutput RadioStack avec l'ancien driver, Androl lui a Saitek panel(s) Plugin for FSX avec le nouveau plugin...

Mais la commande et le path doit être bon, pour que l'ouverture de votre P3D lance SaiFlightSimX.exe, l'exécutable des FIP

Au final, vous devriez avoir un truc comme ça pour votre exe.xml:

<?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document Type="Launch" version="1,0">
    <Descr>Launch</Descr>
    <Filename>exe.xml</Filename>
    <Disabled>False</Disabled>
    <Launch.ManualLoad>False</Launch.ManualLoad>
        <Launch.Addon>
            <Name>Saitek DirectOutput RadioStack</Name>
            <Disabled>False</Disabled>
            <Path>C:\Program Files (x86)\Saitek\DirectOutput\SaiFlightSimX.exe</Path>
            <CommandLine>-run</CommandLine>
        </Launch.Addon>

</SimBase.Document>

Bonne chance! et n'oubliez pas la sauvegarde...

Dernière modification par Bobonhom (18-10-2018 21:54:49)


https://i.goopics.net/oYwXe.jpghttps://i.goopics.net/4Wd7b.jpghttps://i.goopics.net/20XRJ.jpg

Hors ligne

 

#470 [↑][↓]  28-10-2017 18:49:42

Bobonhom
Pilote Virtuel
Membre donateur
Lieu: Les Laurentides Québecoise
Date d'inscription: 24-04-2012
Renommée :   119 
Site web

Re: [FS9][FSX][P3D] Tuto SPAD l'ami des panels Saitek... Enfin dispo P3Dv4

Et maintenant le sacré problème des LED éteints encore sur le Multi-Panel Saitek...

Voici tous les causes possibles que j'ai répertorié pour le même problème:



MASTER AVIONICS

La plus stupide, mais le plus facile à corriger wink

Les avions ont pour la plupart, un master avionics, il faut qu'il soit bien sûre ON pour que les LED allume, que ce soit sur le multi-panel, ou les modules radio Saitek... Ce qui est tout à fait normal wink



GESTION USB (économie énergie)

Depuis W8, c'est un peu le capharnaüm pour la gestion d'énergie des usb... Je t'invite à voir mon tuto pour réglé cela:

PROBLÈME DE DÉCONNEXION PÉRIPHÉRIQUE



L'ALIMENTATION

Il faut qu'il soit bien alimenté, il demande du jus ce module... Et une connexion en USB2, le USB3 cause problème avec à peu près tout ce qui est Saitek...... Un bon HUB externe avec alimentation indépendante règle souvent le problème... Prévoir un alimentation de .5 amps par sortie...



DRIVERS et W10

J'ai lu que plusieurs ont ce problème, le règle, mais que le problème revient avec les différentes mises à jours de W10

Si tu as installé les drivers Saitek (ou Logitech) peut-être essayer ceci:
MENU DÉMARRER... Tous les programme... Saitek... Multi panel... Cliquer sur "Launch the Flight Sim X manually".



POUR DE MEILLEUR DRIVERS

Le logiciel SPAD fait merveille avec les modules Saitek... Non seulement il est plus stable que les drivers d'origine, mais permettre aussi ta propre programmation...

Voir mon tuto SPAD pour te faire une idée: [FS9][FSX][P3D] Tuto SPAD l'ami des panels Saitek... Enfin dispo P3Dv4

Seul hic, sous P3Dv4 il y a problème si utilisé en même temps que FIP Saitek... Mais je vois que tu est sous FSX, donc pas de problème... Ce problème est maintenant réglé par un drivers pour FIP seulement en 64 bit




Et voilà, je crois avoir fait le tour de la question, revienez moi.... Avec des résultats wink

Bonne chance à tous et bon vol!

Dernière modification par Bobonhom (28-10-2017 18:50:19)


https://i.goopics.net/oYwXe.jpghttps://i.goopics.net/4Wd7b.jpghttps://i.goopics.net/20XRJ.jpg

Hors ligne

 

#471 [↑][↓]  05-11-2017 22:34:04

velo19
Pilote confirmé
Date d'inscription: 01-10-2008
Renommée :   
Site web

Re: [FS9][FSX][P3D] Tuto SPAD l'ami des panels Saitek... Enfin dispo P3Dv4

Bonsoir les amis,

Je viens de mettre à jour Windows 10 64 bits aujourd'hui et depuis les modules saitek ne marchaient plus. Après avoir réglé les problèmes d'alimentation sur les ports usb (j'ai un hub alimenté) et réinstaller spad 0.7 avec le bon raccourçi cela va mieux mais c'est le saitek panel qui déconne l'allumage ne va pas sur off, les deux boutons d'avionic master ne fonctionnent plus et deux autres boutons ne marchent plus également.

Une idée car avant cette mise à jour tout marchait nickel.

NB : Je suis sur P3DV4.1.

Merci pour vos suggestions.

Bonne soirée.


ASUS P8Z77-V, I5 3570K 3.4Ghz @ 4.2 Ghz, 16Go Crucial 1600, 1 DD500Go + 1SSD 500Go et 1To, Tour Armor+, MSI GeForce 1060 6Gb,  Alim Corsair HX620W, WIN 7 64, Yoke, Quad, Trim, Switch Panel + Multi Panel Saitek (drivers Spad), avec Homecockpit, UTX2, REX+OverdrivePlus, FSma32, EzDok, 2 PC en réseaux, 1 écran TV Samsung 101cm LED 3D, webmaster de velo19.com

Hors ligne

 

#472 [↑][↓]  06-11-2017 07:15:32

Bobonhom
Pilote Virtuel
Membre donateur
Lieu: Les Laurentides Québecoise
Date d'inscription: 24-04-2012
Renommée :   119 
Site web

Re: [FS9][FSX][P3D] Tuto SPAD l'ami des panels Saitek... Enfin dispo P3Dv4

Je vois pas trop en quoi un mise à jour Windows mettrais le souk dans SPAD...

Par-contre il faut assurément le dernier FSUIPC...


Et bordel, freiner vos W10, ne mettez que ce qui concerne la sécurité wink


Qu'entends-tu pas ne marche pu... si tu actionne un interrupteur, il bouge sur la fenêtre de reconnaissance SPAD???


https://i.goopics.net/oYwXe.jpghttps://i.goopics.net/4Wd7b.jpghttps://i.goopics.net/20XRJ.jpg

Hors ligne

 

#473 [↑][↓]  06-11-2017 09:37:50

velo19
Pilote confirmé
Date d'inscription: 01-10-2008
Renommée :   
Site web

Re: [FS9][FSX][P3D] Tuto SPAD l'ami des panels Saitek... Enfin dispo P3Dv4

En fait, avant l'installation de cette version sécurité de WIndows 10 64bits (j'ai limité le Windows Update dans ce sens) tout marchait bien. L'installation de cette MAJ a en fait "détruit" mes modifications (paramètrage alimentation USB notamment) et dans un premier temps le Multi PANEL ne fonctionnait plus au niveau de l'écran mais tout le reste marchait y compris le switch panel. Du coup, j'ai réinstallé SPAD en nettoyant en profondeur la version précédente. Mais avant j'ai testé avec les drivers logitec mais le même souçi donc je les ai viré.
Après reinstallation de SPAD c'est le Switch Panel qui disfonctionne et le Radio PAnel et le Multi Panel sont ok.
Je vérifie le fonctionnement avant de lancer P3DV4.1 avec le panneau de contrôle de SPAD (j'actionne un intérrupteur pour voir s'il bouge dans la fenêtre de reconnaissance SPAD).
J'ai bien FSUIPC 5 acheté installé et dernière version.
Ce matin j'ai installé SPAD sur un autre PC (en fait c'est le même PC (boitier) mais connecté sur deux disques durs différents) et le problème est le même qu'initialement c'est le module Multi PANEL qui disfonctionne (pas d'écran) mais le SWITCH Panel est ok.
Conclusion : cela ne vient pas de la maj de Windows 10 car elle n'est pas encore installée sur ce poste, les modules saitek ne sont pas en cause à priori.
J'ai les modules saitek branchés sur un HUB USB avec alimentation électrique (alimentation USB bien paramètrée dans Windows10). J'ai testé un seul module (celui qui ne fonctionné pas) en débranchant les autres modules sur le port USB 2.0 de l'ordi et sur le HUB USB alimenté, le résultat est le même je sèche.
Je pensais que c'était un problème de paramètrage de l'alimentation dans Windows 10 mais j'ai suivi scrupuleusement les conseils ci-dessus avec toutes les modifications à appliquer.
Je vais tenté ce soir de faire une installation sur mon ancien Windows 7 qui se trouve sur mon PC réseau et je vais voir mais je n'arrive pas à comprendre pourquoi cela ne marche pas.
Merci d'avance pour vos conseils.


ASUS P8Z77-V, I5 3570K 3.4Ghz @ 4.2 Ghz, 16Go Crucial 1600, 1 DD500Go + 1SSD 500Go et 1To, Tour Armor+, MSI GeForce 1060 6Gb,  Alim Corsair HX620W, WIN 7 64, Yoke, Quad, Trim, Switch Panel + Multi Panel Saitek (drivers Spad), avec Homecockpit, UTX2, REX+OverdrivePlus, FSma32, EzDok, 2 PC en réseaux, 1 écran TV Samsung 101cm LED 3D, webmaster de velo19.com

Hors ligne

 

#474 [↑][↓]  06-11-2017 17:29:03

velo19
Pilote confirmé
Date d'inscription: 01-10-2008
Renommée :   
Site web

Re: [FS9][FSX][P3D] Tuto SPAD l'ami des panels Saitek... Enfin dispo P3Dv4

Bon et bien tout marche nickel et pourtant je n'ai rien fait... Juste allumer mon PC de nouveau !!!!
Comprends pas... 3 heures à essayer de résoudre le problème hier...
Pourtant hier soir j'ai tout essayé (voir message précédent) et j'ai éteint et rallumé PC plusieurs fois. Il fallait peut-être qu'il se repose...
J'ai horreur de ne pas comprendre mais bon tant mieux et désolé pour vous avoir fait perdre votre temps.
Merci BoBonHom.


ASUS P8Z77-V, I5 3570K 3.4Ghz @ 4.2 Ghz, 16Go Crucial 1600, 1 DD500Go + 1SSD 500Go et 1To, Tour Armor+, MSI GeForce 1060 6Gb,  Alim Corsair HX620W, WIN 7 64, Yoke, Quad, Trim, Switch Panel + Multi Panel Saitek (drivers Spad), avec Homecockpit, UTX2, REX+OverdrivePlus, FSma32, EzDok, 2 PC en réseaux, 1 écran TV Samsung 101cm LED 3D, webmaster de velo19.com

Hors ligne

 

#475 [↑][↓]  16-11-2017 19:28:36

davone
Nouveau pilote
Date d'inscription: 01-06-2016
Renommée :   

Re: [FS9][FSX][P3D] Tuto SPAD l'ami des panels Saitek... Enfin dispo P3Dv4

Bonsoir,

Savez-vous si les Saitek panels fonctionnent sur le FSLabs A320 avec Spad Next ?
Je vous remercie pour votre retour.

Hors ligne

 

Pied de page des forums

Maintenance informatique Lausanne